Commit c1b4157f authored by EKbfh's avatar EKbfh

MOngodb3.6 on Ubuntu18.04

parent d3758e0d
......@@ -42,7 +42,7 @@
msg: |
{{ ansible_distribution_version }} is not an acceptable version of {{ ansible_distribution }} for this role
when:
- ansible_distribution_version is version_compare("16.10", '>')
- ansible_distribution_version is version_compare("18.04", '>')
- name: Fail for a old release of Ubuntu
fail:
......
......@@ -23,6 +23,24 @@
environment:
https_proxy: "{{ http_proxy }}"
http_proxy: "{{ http_proxy }}"
when:
- ansible_distribution == "Ubuntu"
- ansible_distribution_version != "18.04"
tags:
- repo
- name: Add MongoDB repository on Ubuntu-18
apt_repository:
repo: "deb http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/{{ mongod_version }} multiverse"
state: present
update_cache: "True"
register: mongo_repo_stat
environment:
https_proxy: "{{ http_proxy }}"
http_proxy: "{{ http_proxy }}"
when:
- ansible_distribution == "Ubuntu"
- ansible_distribution_version == "18.04"
tags:
- repo
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment