Commit 712f6836 authored by Aleksey Shirokih's avatar Aleksey Shirokih
Browse files

Update info

parent b219d48d
docker-compose installation # docker-compose installation
===========================
The best way of launching tower is to setup it via docker and docker compose. The best way of launching tower is to setup it via docker and docker compose.
Example file for launching noc-tower via docker-compose can be found in [repositary](https://code.getnoc.com/noc/tower/blob/master/docker-compose.yml) Updating tower as simple as
```
cd /etc/docker-compose/tower
docker-compose pull
docker-compose up -d
```
If you are using install without docker there is [migration guide](docs/migrate_dc.md)
Some examples can be found in [FAQ_rus.md](FAQ_rus.md) in russian
<details>
<summary>Also there is a way to update tower manually </summary>
Traditional installation
========================
Meanwhile old method of updating noc-tower is still supported. Meanwhile old method of updating noc-tower is still supported.
To do so To do so
check if pip version is greater than 1.5 to do so check if pip version is greater than 1.5 to do so
``` <pre><code>
# cd /opt/tower # cd /opt/tower
# ./bin/pip --version # ./bin/pip --version
# ./bin/pip install --upgrade pip # ./bin/pip install --upgrade pip
# ./bin/pip --version # ./bin/pip --version
``` </code></pre>
than than
``` <pre><code>
# cd /opt/tower # cd /opt/tower
# ./bin/tower-upgrade # ./bin/pip install --upgrade https://cdn.getnoc.com/tower/noc-tower-latest.zip
``` </code></pre>
After it please recheck if ansible version is good enough. Current is is 2.3 After it please recheck if ansible version is good enough. Current is is 2.5
If you get <pre><code>
```ERROR! Invalid callback for stdout specified: debug```
error after updating Please double check ansible version with
```
# cd /opt/tower # cd /opt/tower
# ./bin/ansible --version # ./bin/ansible --version
ansible 2.3.0.0 ansible 2.5.0
config file = config file =
configured module search path = Default w/o overrides configured module search path = Default w/o overrides
``` </code></pre>
If ansible version is too old update it with If ansible version is too old update it with
``` <pre><code>
# ./bin/pip install --upgrade ansible # ./bin/pip install --upgrade ansible
``` </code></pre>
\ No newline at end of file
</details>
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment